#dominoforever | Product Ideas Portal

 

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.

For more information and upcoming events around #dominoforever, please visit our Destination Domino Page

Update to release notes for Traveler 10.0.1.0 - schema update also needed for DB2 setup if NTS_AUTO_DBSCHEMA=false when upgrading from an earlier release

The customer recently upgraded from traveler 9.0.1.21 to Traveler v10.0.1.0, and found after this that traveler would not start as the schema version was not valid:

Traveler: Database is configured with minimum schema version 20140619 and maximum schema version 20160812

Traveler: Waiting for valid minumum or maximum database schema before starting.

 -> so an update of the schema was needed as they were going from an older release.

 

The customer feels that the release notes "Traveler 10.0.1.0 Server Release Documentation"- https://www-01.ibm.com/support/docview.wss?uid=ibm10742533 seem to indicate that the update to the schema in traveler 10.0.0.0 which is needed if auto schema updates are disabled i.e if NTS_AUTO_DBSCHEMA=false (By default this is set to True), was only needed for those using mySQL:

"Note for customers that manage their database schema: IBM Traveler 10.0.1.0 does not include a database schema update, however Traveler 10.0.0.0 had a small schema update for MS SQL Server deployments. "

->whereas the referenced document "Updating the enterprise database" https://www.ibm.com/support/knowledgecenter/en/SSYRPW_9.0.1/UpdatingTheEnterpriseDatabase.html seems to indicate that the update is needed for any Enterprise DB server (DB2, SQLSERVER, or AS400)

The customer would like this release documentation updated so as to avoid confusion, i.e that the update is also needed for DB2 setup, not just an SQL setup..

  • Avatar32.5fb70cce7410889e661286fd7f1897de Guest
  • Jan 28 2019
  • Shipped