#dominoforever | Product Ideas Portal

 

Welcome to the #dominoforever Product Ideas Forum! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated by HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.

For more information and upcoming events around #dominoforever, please visit our Destination Domino Page

Rename the event handlers and sort them by meaning, not alphabetically

The names of the event handlers like onShow, onItemFocus etc. are meaningful - at least for JavaScript programmers. But it's at least a "hurdle" for the citizen developer.

Give them more descriptive names in clear English and add the JavaScript names in brackets, like:

when form shows (onShow)

when field gets the focus (onItemFocus)

Then sort and group the item handlers by meaning:

onShow and onHide one after the other

onValid and onInvalid one after the other

and so on.

  • Guest
  • Jun 2 2020
  • Attach files